Thank you for purchasing the Janome Robot.

*Read this manual thoroughly in order to properly use this robot. Be sure to read “For Your Safety” before you use the robot. It will protect you from possible dangers during operation.

*After having read this manual, keep it in a handy place so that you or the operator can refer to it whenever necessary.
FOR YOUR SAFETY

Safety Precautions

The precautions stated in this manual are provided for the customer to make the best use of this product safely, and to provide preventive measures against injury to the customer or damage to property.

・・・・・ Be sure to follow the instructions・・・・・

Various symbols are used in this manual. Please read the following explanations to understand what each symbol stands for.

● Symbols indicating the Degree of Damage or Danger
The following symbols indicate the degree of damage or danger which may be incurred if you neglect the safety notes.

⚠️ Warnings These “Warnings” indicate the possibility of death or serious injury.

⚠️ Cautions These “Cautions” indicate the possibility of accidental injury or damage to property.

● Symbols indicating the type of Danger and Preventive Measures
The following symbols indicate the type of safety measure that should be taken.

⚠️ Indicates the type of safety measure that should be taken.

⚠️ Take care. (General caution)

🚫 Indicates prohibition.

🚫 Never do this. (general prohibition)

🚫 Do not disassemble, modify or repair.

🚫 Do not touch. (contact prohibition)

● Indicates necessity

⚠️ Be sure to follow instructions.

🚫 Be sure to unplug power supply from wall outlet.

🚫 Be sure to check grounding.
## FOR YOUR SAFETY

### <JS/JSG Series>

<table>
<thead>
<tr>
<th>Warnings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Do not leave the unit plugged in (power cord and connectors) when it is not in use for long periods of time. Dust can cause fire.</td>
</tr>
<tr>
<td><strong>Be sure to shut off the power supply before removing the power cord.</strong></td>
</tr>
<tr>
<td>Change the robot's battery periodically (approximately every three years) to prevent malfunction or breakdown.</td>
</tr>
<tr>
<td>Keep the emergency stop switch within reach of an operator while teaching and running the robot. Failure to do so may cause danger since the robot cannot be stopped immediately and safely.</td>
</tr>
<tr>
<td>Regularly check that the I/O-S circuits and emergency stop switch work properly. Failure to do so may cause danger since the robot cannot be stopped immediately and safely.</td>
</tr>
<tr>
<td>Check the mounting screws regularly so that they are always firmly tightened. Loose screws may cause injury or defect.</td>
</tr>
<tr>
<td><strong>Power the unit only with the rated voltage.</strong> Excessive voltage can cause fire or malfunction of the unit.</td>
</tr>
<tr>
<td>Do not sprinkle water or oil on the unit, control box, or its cable. Contact with water can cause electric shock, fire, or malfunction of the unit. IP Protection Rating is IP40.</td>
</tr>
</tbody>
</table>
FOR YOUR SAFETY

INSTALLATION

⚠️ Warnings

Always use a safety barrier. A person entering the robot’s restricted area may be injured. At the entry/exit gate of the safety barrier, install an interlock that triggers an emergency stop when the gate is opened. Ensure there is no other way of entering the restricted area. Furthermore, put up a “No Entry” or “No Operating” warning sign in a clearly visible position.

Example

Install a safety barrier of adequate strength so as to protect the operator from moving tools and flying objects. Always use protective wear (helmet, protective gloves, protective glasses, and protective footwear) when going inside the safety barrier.

Take adequate precautions against objects the robot is gripping flying or falling off taking into account the object's size, weight, temperature and chemical composition.
## Warnings

- **Confirm that the unit is properly grounded.**
  
  Power supply earth should be connected complying with Type D installation. (under 100 Ω of resistance.)

  Insufficient grounding can cause electric shock, fire, or malfunction of the unit.

- **Plug the power cord into the wall outlet firmly.**

  Incomplete insertion into the wall outlet makes the plug hot and can cause fire.

  Check that the plug is not covered with dust.

  Be sure to shut off the power supply before connecting the power cord to the control box.

- **Place the unit on a suitable flat surface that can support its weight.**

  Be sure to leave a space greater than 30cm between the back of the robot (equipped with a cooling fan) and the wall.

  An insufficient or unstable area can cause the unit to fall, overturn, breakdown, or overheat.

- **Do not attempt to disassemble or modify the machine.**

  Disassembly or modification may cause electric shocks, fire or malfunction.

- **Be sure to use within the voltage range indicated on the unit.**

  Failure to do so may cause electric shock or fire.

- **Do not use the unit near inflammable or corrosive gas.**

  If leaked gas accumulates around the unit, it can cause fire.

  IP Protection Rating is IP40.

- **Place the unit in a well-ventilated area for the health and safety of the operator.**

- **Turn off the unit before inserting and removing cables.**

  Failure to do so may result in electric shock, fire, or malfunction of the unit.

  IP Protection Rating is “IP40.”
FOR YOUR SAFETY

⚠️ Warnings

- Be sure to confirm that all the air tubes are connected correctly and firmly.
- Use the robot in an environment between 0 to 40 degrees centigrade with a humidity of 20 to 95 percent without condensation. Failure to do so may result in malfunction. IP Protection Rating is “IP40.”
- Use the robot in an environment where no electric noise is present. Failure to do so may result in malfunction or defect.
- Be sure to secure the movable parts of the robot before transportation. Failure to do so may result in defect or injury.
- Do not bump or jar the machine while it is being transported or installed. This can cause defects.
- Use the machine in an environment where it is not exposed to direct sunlight. Failure to do so may result in malfunction or defect.
- Be sure to confirm that tools such as the electric screwdriver unit, etc. are properly connected. Failure to do so may result in injury or defect.
- Be sure to check the wiring to the main unit. Improper wiring may cause malfunction or defect.
- Keep the emergency stop switch within reach of an operator while teaching and running the robot. Failure to do so may cause danger since the robot cannot be stopped immediately and safely.
- Be sure to shut off the power supply before plugging the power cord.
FOR YOUR SAFETY

⚠️ Warnings

Be sure to remove the eye bolt after installing the robot so that it does not hit the arm.
Failure to do so may result in injury or breakdown of the unit.
## FOR YOUR SAFETY

### WORKING ENVIRONMENT

<table>
<thead>
<tr>
<th>Warnings</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>When you lubricate or inspect the unit, unplug the power cord from the control box.</strong>&lt;br&gt;Failure to do so may result in electric shock or injury.&lt;br&gt;&lt;strong&gt;Be sure to shut off the power supply** before removing the power cord from the control box.</td>
</tr>
<tr>
<td><strong>When going inside the safety barrier, place a “Do Not Operate” sign on the start switch.</strong></td>
</tr>
<tr>
<td><strong>During operation, always have the emergency stop switch within the operator’s reach.</strong>&lt;br&gt;For the operator’s safety, the emergency stop switch is necessary to make a quick and safe stop.</td>
</tr>
<tr>
<td><strong>Install a safety barrier of adequate strength so as to protect operators from moving tools and flying objects.</strong>&lt;br&gt;Always use protective wear (helmet, gloves, glasses, and footwear) when going inside the safety barrier.</td>
</tr>
<tr>
<td><strong>Be sure to confirm that all the air tubes are connected correctly and firmly.</strong></td>
</tr>
<tr>
<td><strong>Always watch out for robot’s movement, even in the teaching mode.</strong>&lt;br&gt;Special attention will protect the operator from injury.</td>
</tr>
</tbody>
</table>
# FOR YOUR SAFETY

## DURING OPERATION

<table>
<thead>
<tr>
<th>Warnings</th>
</tr>
</thead>
<tbody>
<tr>
<td>When operations are taking place within the safety barrier, <strong>ensure no one enters the robot’s restricted area.</strong></td>
</tr>
<tr>
<td>If you must go inside the safety barrier, be certain to <strong>push the emergency stop switch</strong> and put a “Do Not Operate” <strong>sign</strong> on the start switch.</td>
</tr>
<tr>
<td>When starting the robot, check that, <strong>no one is within the safety barrier and no object will interfere with the robot operating.</strong></td>
</tr>
<tr>
<td>Under no circumstances should you go inside the safety barrier or place your hands or head inside the safety barrier while the robot is operating.</td>
</tr>
<tr>
<td>If anything unusual (e.g. a burning smell) occurs, stop operation and unplug the cable immediately. Contact your dealer or the office listed on the last page of this manual. Continuous use without repair can cause electric shock, fire, or breakdown of the unit.</td>
</tr>
<tr>
<td>During teaching, tests, and actual operation, always have the Emergency stop switch within the operator’s reach. For the operator’s safety, the emergency stop switch is necessary to make a quick and safe stop.</td>
</tr>
</tbody>
</table>
## FOR YOUR SAFETY

### <JR2000N Series>

### Warnings

<table>
<thead>
<tr>
<th>Warning</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>⚠️ Be sure to check grounding.</td>
<td>Improper grounding can cause electric shock or fire.</td>
</tr>
<tr>
<td>⚠️ Be sure to use within the voltage range indicated on the unit.</td>
<td>Failure to do so may cause electric shock or fire.</td>
</tr>
<tr>
<td>⚠️ Plug the power cord into the wall outlet firmly.</td>
<td>Failure to do so can cause the input to heat up and may result in fire. Make sure that the power plug is clean.</td>
</tr>
<tr>
<td>⚠️ Be sure to unplug the power cord from the wall outlet when you examine or grease the machine.</td>
<td>Failure to do so may cause electric shock or fire.</td>
</tr>
<tr>
<td>✨ Stop operation and unplug immediately whenever you sense any abnormalities, such as a pungent odor. Immediately contact the dealer from which you purchased the product.</td>
<td>Continued operation may result in electric shock, fire or malfunction.</td>
</tr>
<tr>
<td>⚠️ Install the product in a place which can endure its weight and conditions while running.</td>
<td>Be sure to leave a space greater than 30cm between the back of the robot (equipped with a cooling fan) and the wall. Installation in an insufficient or unstable place can cause the unit to fall, overturn, breakdown, or overheat.</td>
</tr>
<tr>
<td>⚠️ Be sure to take protective measures such as installing an area sensor or enclosure to avoid injury.</td>
<td>Entering the robot’s work range during operation could lead to injury.</td>
</tr>
<tr>
<td>✖️ Do not attempt to disassemble or modify the machine.</td>
<td>Disassembly or modification may cause electric shocks, fire or malfunction.</td>
</tr>
</tbody>
</table>
FOR YOUR SAFETY

⚠️ Warnings

Use the machine indoors where no flammable or corrosive gas is present. Emission and accumulation of such gasses could lead to fire. IP Protection Rating is “IP30.” (“IP40” for CE specification)

Be sure to unplug the power cord from the wall outlet if the robot will remain unused for long periods of time. Gathered dust could lead to fire.

Be sure to use power in the proper voltage range. Failure to do so may result in fire or malfunction.

Keep the unit and the power cables away from water and oil. Failure to do so may result in electric shock or fire.

Turn off the unit before inserting and removing cables. Failure to do so may result in electric shock, fire, or malfunction of the unit. IP Protection Rating is “IP30.” (“IP40” for CE specification)

Keep the emergency stop switch within reach of an operator while teaching and running the robot. Failure to do so may lead to danger since the robot cannot be stopped immediately and safely.

Regularly check that the emergency stop switch works properly. For models with I/O-S circuits, also check that they work properly. Failure to do so may lead to danger since the robot cannot be stopped immediately and safely.
## FOR YOUR SAFETY

### Cautions

- **Be sure to check grounding.**
  Improper grounding may cause malfunction or defect.

- **Use the Desktop Robot in an environment between 0 to 40 degrees centigrade with a humidity of 20 to 95 percent without condensation.**
  Failure to do so may result in malfunction.
  IP Protection Rating is “IP30.” (“IP40” for CE specification)

- **Use the machine in an environment where no electric noise is present.**
  Failure to do so may result in malfunction or defect.

- **Use the machine in an environment where it is not exposed to direct sunlight.**
  Failure to do so may result in malfunction or defect.

- **Be sure to confirm that tools such as the electric screwdriver unit, etc. are properly connected.**
  Failure to do so may result in injury or defect.

- **Check the mounting screws regularly so that they are always firmly tightened.**
  Loose screws may cause injury or defect.

- **Be sure to check the wiring to the main unit.**
  Improper wiring may cause malfunction or defect.

- **Be sure to secure the movable parts of the robot before transportation.**
  Failure to do so may result in defect or injury.

- **Do not bump or jar the machine while it is being transported or installed.**
  This can cause defects.
PREFACE

The “JR C-Points” is an enhanced version of the existing PC software, JR Points. This software will help you to operate the JS series SCARA robot and the JR2000N series robot. Its features are affordable price, cost efficiency, diverse applications, high speed, rigidity and precision. Furthermore, it can accommodate a wide variety of requirements.

By using the “JR C-Points”, you can save, read, add, insert, delete, or edit C&T data, and can also perform JOG teaching operations via PC. You can also register programs via PC, without connecting the teaching pendant.

This operation manual explains how to use the “JR C-Points” software.

Operating methods such as clicking the mouse and use of dialog boxes for “JR C-Points” are the same as those of Microsoft Windows® 2000 applications. For details of Windows® 2000 operating methods, refer to the instruction manual supplied with Windows® 2000.

⚠️ Warning When transmitting C & T data between the PC and the robot, be sure to save the data in a file for backup.

Windows, Excel, Word are registered trademarks of Microsoft Corporation.
Lotus 1-2-3 is a registered trademarks of Lotus Development Corporation.
CONTENTS

PC Operation

FOR YOUR SAFETY ........................................................................................................ i
PREFACE.................................................................................................................. xii
CONTENTS ............................................................................................................... xiii

HARDWARE REQUIREMENTS .................................................................................. 1
CONNECTION .......................................................................................................... 2
INSTALLATION AND UNINSTALLATION .............................................................. 5

START AND EXIT ................................................................................................... 7
SCREEN .................................................................................................................. 9
OPERATION PROCESS ......................................................................................... 11
C&T DATA ............................................................................................................... 12

NEW ....................................................................................................................... 13
OPEN/SAVE ........................................................................................................... 14

COMMUNICATION ................................................................................................. 16
COMMUNICATION SETTING .................................................................................. 18
CONNECTION CONFIRMATION/SYSTEM INFORMATION ........................................ 20

SCREEN DISPLAY ................................................................................................. 21

TEACHING DATA – PROGRAM ........................................................................... 22
TEACHING DATA CHANGE – POINT JOB DATA .................................................. 28
TEACHING DATA CHANGE – ADDITIONAL FUNCTION DATA ........................ 31
TEACHING DATA CHANGE – SEQUENCER PROGRAM .................................... 33
TEACHING DATA CHANGE – RUN MODE PARAMETER .................................... 35

ROBOT OPERATION VIA PC .................................................................................. 36

PC Operation xiii
JS SCARA/JSG GANTRY Robot
JR200N Desktop Robot
HARDWARE REQUIREMENTS

To operate the “JR C-Points”, “JR C-Points Limited Edition (included in the JR2000N Series Operation Manual CD-ROM)” software on your PC, the following is required.

- **Personal Computer**
  Should be configured for use with Windows® 2000/XP.

- **Memory Capacity**
  A minimum of **32 MB of memory** is required to operate the “JR C-Points” or “JR C-Points Limited Edition” normally.

- **Operating System**
  Microsoft Windows®2000/XP

- **Hard Disk Capacity**
  A minimum of **20 MB of hard disk space** is required after installing Windows® 2000/XP.

- **COM Port**
  **One vacant COM port** is required to connect the robot to the PC.

The required memory capacity or hard disk space may vary depending on the system environment. Insufficient hard disk space may cause insufficient memory or trouble while operating.
To transmit teaching data to the robot from the PC, connect the two with an RS-232C straight cable (as illustrated below.)
For details of the communication cable wiring, refer to page 46.

Connect one end of the RS-232C cable to the RS-232C connector on the robot (on the control box for the JS series, on the robot body for the JR 2000N series) and the other end to the COM port (serial connector/RS-232C) on the PC.
When operating the robot via the PC, be sure to disconnect the teaching pendant from the control box and connect a grip switch to the teaching pendant connector instead.

When operating the robot via the PC,
JS Series: Be sure to disconnect the teaching pendant and connect a grip switch to the teaching pendant connector instead.
JR2000N Series: Be sure to disconnect the teaching pendant. (If you use a teaching pendant with an enable switch and an emergency stop switch, connect a grip switch to the teaching pendant connector.)

Be sure to turn off the power to the PC and the robot before inserting or removing the cable.
When operating the robot via the PC, be sure to disconnect the teaching pendant from the control box and connect a grip switch to the teaching pendant connector instead. (If you use a teaching pendant without an enable switch and an emergency stop switch in the JR 2000N series, it is not necessary to connect a grip switch.)
If you use a teaching pendant with an enable switch but without an emergency stop switch with the JR2000N series, use a grip switch with an emergency stop switch only. If you use a teaching pendant with an emergency stop switch but without an enable stop switch, use a grip switch with an enable switch only.
INSTALLATION AND UNINSTALLATION

Install the “JR C-Points” software onto your PC before operation.

■ INSTALLATION
1. Start Windows® and check that it is functioning correctly. Before installation, close all applications.
2. Insert the “JR C-Points” CD-ROM into the CD-ROM drive.
3. The installer automatically starts up. Follow the onscreen instructions.

If the Installer Doesn’t Start up Automatically,
1. Select [Settings] from the Windows® [Start] menu and click [Control Panel.] Double-click [Add or Remove Programs.]
2. Click the [Add New Programs] button and select [CD or Floppy.]
3. Click the [Next] button in the new dialog box and check that the CD-ROM drive “¥SETUP.EXE” is set in the command line of the setup program.
4. Follow the onscreen instructions.

Enter the serial number affixed to the back of the CD-ROM case in one-byte characters.
**UNINSTALLATION**

1. Select [Settings] from the Windows® [Start] menu and click [Control Panel.] Double-click [Add or Remove Programs.]
2. Click [Change or Remove Programs.] Select “JR C-Points” from the currently installed program list and click the [Change/Remove] button.
3. Uninstallation of the JR C-Points will be started.
START AND EXIT

Start
Use one of the following two methods to start up the “JR C-Points” software.
1. Select [Program] from the [Start] menu of Windows® and click [JR C-Points].
2. Click the shortcut icon on the desktop.

The JR C-Points can be started even when the PC and the robot are not connected or when the power to the robot is OFF.
However, a “communication error” will be returned and information stored in the robot will not be read out to the PC.
Set the “Model Name” and “Axis Info” (number of Axis) of your robot and click [OK].
In this case, you cannot operate the robot via the PC.
Exit

Use one of the following two methods to exit the "JR C-Points" software.

- Click [Exit] on the [File] pull-down menu.
  
  or

- Click the (Exit) button on the upper right corner of the screen.

If unsaved C&T data is open, the Exit confirmation dialog box will appear.
C&T Data File Name: Name of the currently open C&T data file
Menu Bar: "JR C-Points" menu: Click an item to display a pull-down menu.
Tool Bar: Shortcut icon alignment
Pull-Down Menu: Appears when clicking an item on the menu bar.
Program Number and Name: Number and name of the currently open (selected) program
Point Data Item: Items can be set to point data
Status Item: Describes the PC status.
Model Name and Axis Info: Model name and Axis of the robot connected to the PC
## Icon Functions

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
<th>Similar Menu Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Folder]</td>
<td>Open a new (C&amp;T data) file.</td>
<td>File – New</td>
</tr>
<tr>
<td>![File]</td>
<td>Open an existing file.</td>
<td>File – Open</td>
</tr>
<tr>
<td>![Overwrite]</td>
<td>Overwrite the currently open file.</td>
<td>File – Save As</td>
</tr>
<tr>
<td>![Print]</td>
<td>Print</td>
<td>File – Print</td>
</tr>
<tr>
<td>![Cut]</td>
<td>Cut the currently selected point.</td>
<td>Edit – Cut</td>
</tr>
<tr>
<td>![Copy]</td>
<td>Copy the selected cell to the clipboard.</td>
<td>Edit – Copy</td>
</tr>
<tr>
<td>![Paste]</td>
<td>Paste the clipboard contents to the cell.</td>
<td>Edit – Paste</td>
</tr>
<tr>
<td>![Redisplay]</td>
<td>Redisplay</td>
<td>View – Refresh</td>
</tr>
<tr>
<td>![Version]</td>
<td>Display the “JR C-Points” version information.</td>
<td>Help – Version Information</td>
</tr>
<tr>
<td>![Add Point]</td>
<td>Add a (PTP) point to the end of the program.</td>
<td>Edit – Add Point</td>
</tr>
<tr>
<td>![Insert Point]</td>
<td>Insert a (PTP) point.</td>
<td>Edit – Insert Point</td>
</tr>
<tr>
<td>![Delete Point]</td>
<td>Delete a point.</td>
<td>Edit – Delete Point</td>
</tr>
<tr>
<td>![Add PTP]</td>
<td>Add a PTP point to the end of the program.</td>
<td></td>
</tr>
<tr>
<td>![Add CP Start]</td>
<td>Add a CP start point to the end of the program.</td>
<td></td>
</tr>
<tr>
<td>![Add CP Pass]</td>
<td>Add a CP passing point to the end of the program.</td>
<td></td>
</tr>
<tr>
<td>![Add CP Stop]</td>
<td>Add a CP stop point to the end of the program.</td>
<td></td>
</tr>
<tr>
<td>![Add CP Arc]</td>
<td>Add a CP arc point to the end of the program.</td>
<td></td>
</tr>
<tr>
<td>![Add CP End]</td>
<td>Add a CP end point to the end of the program.</td>
<td></td>
</tr>
<tr>
<td>![Add PTP Evasion]</td>
<td>Add a PTP evasion point to the end of the program.</td>
<td></td>
</tr>
<tr>
<td>![Motor Power]</td>
<td>Turn the motor power to the robot ON. (JS Series)</td>
<td>Robot – Motor Power ON</td>
</tr>
<tr>
<td>![Mechanical Initialization]</td>
<td>Execute mechanical initialization of the robot. (JR2000N Series)</td>
<td>Robot – Mechanical Initialization</td>
</tr>
<tr>
<td>![JOG]</td>
<td>Operate the robot in JOG mode.</td>
<td>Robot – JOG</td>
</tr>
<tr>
<td>![Go Move]</td>
<td>The robot executes a “GO MOVE” operation. (To change settings of a point)</td>
<td>Robot – Go Move</td>
</tr>
<tr>
<td>![Go Plus Move]</td>
<td>The robot executes a “GO plus MOVE” operation. (To confirm settings of a point)</td>
<td>Robot – Go Plus Move</td>
</tr>
<tr>
<td>![Point Playback]</td>
<td>The robot executes a point playback.</td>
<td>Robot – Point Playback</td>
</tr>
<tr>
<td>![Test Run]</td>
<td>The robot executes a test run.</td>
<td>Robot – Test Running</td>
</tr>
<tr>
<td>![Add Program]</td>
<td>Add a program.</td>
<td>Program – Add Program</td>
</tr>
<tr>
<td>![Delete Program]</td>
<td>Delete the currently selected program.</td>
<td>Program – Delete Program</td>
</tr>
</tbody>
</table>

* Click [Toolbar] on the [View] pull-down menu to display or hide the icons.
The following chart shows the process for creating C&T data with this application and sending the data to the robot.

*1: In this case, "file" indicates the extension ".cps" file stored in the PC.
*2: Before sending C&T data to the robot, be sure to back up the data to a file in case of communication error.
C&T DATA

This section explains the C&T data handled with this application. “C&T” stands for Customizing and Teaching data.
In this application, the teaching data is always handled (e.g. File Open, Save File, Send to Robot, Receive from Robot) in combination with the customizing data. The unit of data is called “C&T data.” You cannot save, receive and send only the teaching data or only the program.
Only one unit of C&T data can be saved in the robot at one time. Accordingly, if you send the C&T data from the PC to the robot, the data stored in the robot will be overwritten (deleted.)

The C&T data contains all the setting values and data stored in the robot except the settings below. (You cannot change the settings below by PC.)
When changing any of the settings except the following or creating and editing any program or point job data, open the C&T data first.

- Teaching Environments Setting
  (Settings displayed by pressing the [T.ENV] key on the teaching pendant)

- Administration Settings
  - Start Channel
  - Program Number Change Invalid
  - COM Setting
Click [New] on the [File] pull-down menu.

The new C&T data file will open. In this case, no contents are displayed on the screen since no program is open.

A new C&T data file opens when the application is started up.

- You cannot open multiple units of C&T data at one time. If a C&T data file is already open, close it before opening a new C&T data file.
This section explains how to open or save to a C&T data file in the PC. To change or open the C&T data in the robot, refer to the "Communication" section on page 16. Before sending the C&T data to the robot, back up the data to a file in case of error.

■ Save to (.cps) File

Click [Save] or [Save As] on the [File] pull-down menu.

When saving the data in a file, if any setting value included in the C&T data exceeds the entry range, the upper/lower value of the range is saved instead. However, if a sequencer program number and a point data or additional function data number assigned to the point data exceeds the entry range, “0” (meaning "not registered") is saved.
Open (an Extension “.cps”) File

   You cannot open multiple units of C&T data at one time. If a C&T data file is already open, close it before opening a new C&T data file.

2. Select a file to be opened.

Read JCS File (an Extension “.cps” File)
You can convert a CAD drawing (DXF file) into a JCS file using the Dxf2Robot software and read it.

1. Click [Import] on the [File] pull-down menu.

2. Select a file to be opened.
   The JCS file length is not fixed. Select the unit of length (mm/inch) here.

3. Select a number for the data included in the JCS file (a program number from the C&T data) and click [OK.]

   If the C&T Data Is Not Open
   The screen displays new C&T data which contains only one (selected) program.

   If the C&T Data Is Already Open
   The screen displays that a new (selected) program has been added to the currently open C&T data.

- Once opened, a JCS file cannot be saved again unless converted into a (.cps) C&T data file.
COMMUNICATION

Before using created C&T data, it has to be transmitted to the robot. To open the C&T data file currently being used in the robot, it has to be transmitted to the PC.

When using this application, all data is handled in the unit (C&T data) described in the previous section. You cannot send or receive a specific program or specific point data even when transmitting data between the PC and the robot.

- Be sure to send, receive, or read information between the robot and the PC under the following conditions.
  - Teaching base condition
    (The point setting screen or new position entry screen is displayed in the teaching mode.)
  - Wait for start condition
    (The robot is waiting for start at the work home position either in the run or external run mode.)
  - Customizing mode base condition
    (The customizing mode menu screen is displayed.)
  - Administration mode base condition
    (The administration mode menu is displayed.)

■ How to Receive Data
Click [Receive C&T Data] [Robot] on the [Robot] pull-down menu. The robot will start to send the C&T data to the PC. When the transmission is complete, the received C&T data will open.

- You cannot open multiple units of C&T data at one time. If C&T data is already open, close it before receiving new C&T data.
How to Send Data

Click [Send C&T Data] on the [Robot] pull-down menu.

The PC will start to send the C&T data to the robot.

When sending data, if any setting value included in the C&T data exceeds the entry range, the upper/lower value of the range is transmitted instead. However, if a sequencer program number or a point job data or additional function data number assigned to the point data exceeds the entry range, "0" (meaning "not registered") is transmitted.

Only one unit of the C&T data can be saved in the robot at one time. Accordingly, if you send C&T data from the PC to the robot, the data stored in the robot will be overwritten (deleted.) To save data stored in the robot in a file, close the data file to be transmitted briefly and click [Receive C&T Data.]

When transmitting C&T data while logged in, the PC will log out if the data does not contain the account you are logged in under.
COMMUNICATION SETTING

This section explains how to set communication parameters. When sending or receiving data between the robot and the PC, select a COM Port for the PC and match the communication parameters of the PC and the robot. You cannot confirm or set the communication parameters for the robot via PC.

■ PC Communication Parameters

Click [COM Status] on the [Robot] pull-down menu. Set up or confirm the communication settings for the PC.

Select the same [COM Port] number as that of the connector on the PC connected to the robot.

For the PC COM Port number, refer to the instruction manual for your PC.

Set or confirm each parameter setting other than the [COM Port] number to match that of the robot.

- This setting is valid only for communication with this application.
Robot Communication Parameters

You cannot confirm or set the communication parameters for the robot via the PC. To confirm or set the communication parameters for the robot, connect the teaching pendant to the control box.

Start the robot in the Administration mode.

Select [Administration Settings Mode] from the Administration menu.

Select [COM Setting] from the Administration Settings Mode menu to display the COM Setting screen. (See right)

Select [COM1 Communication Setting] to display the COM1 communication settings. (See right)

Confirm that each parameter setting matches the PC communication parameters.
CONNECTION CONFIRMATION
SYSTEM INFORMATION

Click [Robot] on the menu bar and then click [SystemInfo] on the pull-down menu. Information about the robot connected will be read out.

- “Robot System Software Ver. Number” is the system version number built into the robot, not the version number of “JR C-Points.”

The “System Information” function can be used to confirm the connection between the PC and the robot. Try this when communication with the robot fails or when the robot cannot be operated. If the system information cannot be read out, confirm the following. If the system information still cannot be read out, try [Diagnosis Mode] (teaching pendant required) or contact your dealer.

<Unable to Connect>

The power to the robot is ON.

The cable is connected

Each communication parameter is same.

RS-232C cable is used.

- Confirm that the “COM Port” number set in the “COM Status” is the same as the COM Port number of the PC connected to COM1 of the robot.

- Confirm that “COM1 Communication Settings” for the robot are the same as the “COM Status” for the PC (except for the “COM Port” number.)
SCREEN DISPLAY

This section explains how to change or restore the screen display.
Click [View] on the menu bar to display the following pull-down menu.

■ Tool Bar
Click this to display or to hide the tool bar.

■ Status Bar
Click this to display or to hide the status bar.

■ Refresh
Click this to redisplay the point data.
If any setting value included in the data exceeds the entry range, the upper/lower value of the range is displayed instead. However, if a sequencer program number and point data or additional function data number assigned to the point data exceeds the entry range, “0” (meaning “not registered”) is displayed.

■ Change View
Click this to select the point data display, horizontal or vertical.

■ Unit System
Click this to select the unit of length or coordinates from the following.
- mm (millimeter)
- in (inch)

■ Set View Language
Captions created in customizing mode can be displayed in a specified language.
If a caption is not set with specified language, it will be displayed in English.
TEACHING DATA – PROGRAM

- Open Program
  A program is a part of the C&T data. To open a program, open C&T data first.

- New Program
  To open a new program, click [Add Program] on the [Program] pull-down menu. The following dialog box will appear. Select a new program number to be registered and enter a name. You can use up to ten one-byte characters.

  You cannot select a program number that is already registered.

- Existing Program
  Click the “▼” mark on the right of the program name display. (See below) The list of programs included in the C&T data will be displayed. Select the desired program to be opened.

You can also display the program list and select the desired program by clicking [Program] on the menu bar and [Program Change] on the pull-down menu.
■ Program Data

When a new program is opened, the following dialog box will be displayed. Click a tab to enter or select a desired value. After entering the value, click [OK].

This dialog box can also be viewed by clicking [Program Data] on the [Program] pull-down menu.
Point Data

After opening a program using [Add Program], the point data alignments will be blank.

To register more than one point in a program, repeat [Add Point] as many times as required.

Point Data Item

Point Data

- Enter/Change a Value
  
  Click a cell and enter a value to be registered using the keyboard.
  
  In the [Type] line, the “˝” mark will appear on the right of the cell when a cell is clicked. Click this to display the list of point types. Select the point type to be registered.

- Edit
  
  Select a cell or point to be edited and click [Edit] on the menu bar. The Edit menu will appear.
  
  This menu also appears by selecting a cell or point to be edited and right-clicking it.
  
  To select a point, select all cells included in the point (except the point number line) or click the point number.
• **Cut**
  The [Cut] operation is executed in points.
  Select a cell and click [Cut] on the [Edit] pull-down menu. The point including the selected cell will be deleted.
  After the [Cut] operation, select a cell and click [Paste] on the [Edit] pull-down menu. The clipped point will be inserted in front of the selected cell.

• **Copy**
  Cell: Select a cell as copy source and click [Copy] on the [Edit] pull-down menu. Then select a cell as copy destination and click [Paste] on the [Edit] pull-down menu. The copy source cell will be overwritten onto the copy destination cell.
  Point: Select a point as copy source and click [Copy] on the [Edit] pull-down menu. Then select a point as copy destination and click [Paste] on the [Edit] pull-down menu. The copied point will be inserted in front of the point where the cursor is blinking.
  Click [Paste After Last Point] to add the copied program to the end of the program.

• **Paste/Paste After Last Point**
  By using these functions, you can paste not only the “clipped” or “copied” cell and point but also data created by other applications, such as Lotus 1-2-3, Microsoft Excel®, and Word®.

• **Add Point**
  Click [Add Point] on the [Edit] pull-down menu. A point will be added to the end of the point data alignments.

• **Insert Point**
  Click [Insert Point] on the [Edit] pull-down menu. A point will be inserted in front of the point data where the cursor is blinking.

• **Delete Point**
  Click [Delete Point] on the [Edit] pull-down menu. The point data where the cursor is blinking will be deleted.

• The [Add Point], [Insert Point], and [Delete Point] operations also can be executed by clicking the icons in the tool bar.
• **Block Copy**  
The [Block Copy] operation is executed in points.  
Select a cell and click [Block Copy] on the [Edit] pull-down menu.  
The Block Copy dialog box will appear.  
Enter the range of copy source points (Start Point Number and End Point Number), copy count (Copy Times) and offsets (Offset X, Y, Z, R), and then click [OK.]  
The copied point block will be inserted just behind the original block.

• **Mirror Copy (Right-Left/Front-Back)**  
The [Mirror Copy] operation is executed in points.  
Select a cell and click [Mirror Copy] on the [Edit] pull-down menu.  
The Mirror Copy dialog box will appear.  
Enter the range of copy source points (Start Point Number and End Point Number) and mirror position (Mirror Position X/Y), and then click [OK.]  
The copied point block will be inserted just behind the original block.

• **Offset Move**  
The [Offset Move] operation is executed in points.  
Select a cell and click [Offset Move] on the [Edit] pull-down menu.  
The Offset Move dialog box will appear.  
Enter the range of offset move points (Start Point Number and End Point Number) and offsets (Offset X, Y, Z, R), and then click [OK.]  
The designated point coordinates will be converted.

• **Block Rotation**  
The [Block Rotation] operation is executed in points.  
Select a cell and click [Block Rotation] on the [Edit] pull-down menu.  
The Changing Rotating Position dialog box will appear.  
Enter the range of block rotation points (Start Point Number and End Point Number), center of rotation and rotation angle, and then click [OK.]  
The designated point coordinates will be converted.

• **Multiple Line Speed**  
Line speed within the designated range of points can be converted in percentages.  
If the converted value exceeds the setting range, the upper or lower value will be set instead.  
Click [Multiple Line Speed] on the [Edit] pull-down menu.  
The Multiple Line Speed dialog box will appear.  
Enter the Start Point Number, End Point Number and Line Speed Rate, and then click [OK.]
• Reverse Point
Use this function to reverse the order of points within the designated range.
Click [Reverse Point] on the [Edit] pull-down menu. The Point Reverse dialog box will appear.
Enter the Start Point Number and End Point Number, and then click [OK.]

e.g. Start Point Number: 3, End Point Number: 5
    P1, P2, P3, P4, P5, P6 → P1, P2, P5, P4, P3, P6

• Transform into Relative
Use this function to convert the point coordinates in the currently selected program to the relative coordinates.

• 2-Points Position Conversion
By designating two points of the conversion source and the corresponding two points of the conversion destination, you can execute X, Y, and Z parallel and rotational transform.
Click [2-Points Position Conversion] on the [Edit] pull-down menu. The 2-Points Position Conversion
dialog box will appear. Select the conversion range. Enter “Source Position” and “Destination Position”, and then click [Calculate Amount.] The “Converting Amount” will be calculated. Click
[Converting Data] to convert the data coordinates within the designated range according to the converting amounts.

Coordinate conversion data (Source Position, Destination Position, and Converting Amount) used here is not included in the C&T data. Accordingly, this data can neither be transmitted between the PC and the robot nor be saved in a file.
TEACHING DATA CHANGE – POINT JOB DATA

Point job data is a part of the C&T data. Before creating and editing point job data, you need to open the C&T data.

Click [Point Job] on the [Data] pull-down menu. The list of point job data will appear.

- **Copy**
  Copy and edit existing point job data to create similar data.
  1. Select the point job data to be copied from the list and click [Copy]. The selection or entry dialog box for the copy destination point job number will appear.
  2. Select or enter the copy destination point job number.

- **Delete**
  1. Select the point job data to be deleted from the list and click [Delete].
  2. The Delete confirmation screen will appear. Confirm that the number is correct and click [OK].

---

PC Operation

JS SCARA/JSG GANTRY Robot
JR2000N Desktop Robot
New (Add)

1. Click [Add] at the lower left of the list and select a point data number. The Point Job Data Edit dialog box will appear. You cannot select numbers already registered.

- You can change the size of the point job data edit dialog box. Click the "[ ]" button on the upper right corner of the dialog box to make it full-screen. Click and drag the edge of the dialog box to change the size.
2. Select (Click) the desired command to enter or select the necessary parameters for the selected command.

3. Enter or select (click) the necessary parameter(s.)  You can enter the numeric parameters using the keyboard.

4. Click [Register.]  One command line will be registered and the highlight will shift to the next line.

5. Repeat the above steps 3 – 5 as many times as required.

6. After entering all the commands, click [OK.]

When entering the point job name, you can use up to 40 one-byte characters.

- The above steps 3 – 7 are also used when entering “Additional Function Data” and “Sequencer Program” commands.

■ Edit

Use this function to correct existing point data.

1. Select the desired point job data number and click [Edit] at the bottom of the list.  The point job data edit dialog box will appear.

2. After one of the following operations, click [OK.]

   Add a Command _ Select the last line of a command line (that contains no command) on the left side of the screen. Then select (click) or enter “command” and “necessary parameter(s)” in the order described above.  Click [Register.]

   Insert a Command _ Select the desired command line on the left side of the screen. Then select (click) or enter “command”, and “necessary parameter(s)” in the order described above.  Click [Register.]

   One command line will be inserted in front of the selected command line and the following command lines will shift downward.

   Delete a Command _ Select the desired command line on the left side of the screen and Click [Delete.]  The selected command line will be deleted and the following commands will shift upward.

   Change a Command _ After inserting a new command, delete the desired command.

- The above step 2 is also used when changing “Additional Function Data” and “Sequencer Program” commands.
Additional function data is a part of the C&T data. Before creating and editing additional function data, you need to open the C&T data. Click [Additional] on the [Data] pull-down menu. The Additional Function Data list will appear. Select the desired additional function data to be created or changed.

To create new additional function data, click [Add] and select a number from the unentered number list.
To change existing additional function data, select the desired data number to be changed from the list (see below) and click [Edit]. The edit dialog box for the selected additional function data will appear.
■ Edit
To edit existing additional function data, select the desired data number to be edited from the list and click [Edit.]. The edit dialog box for the selected additional function data will appear.

- [PTP Condition], [CP Condition], [Tool Data], [Pallet Routine], [Work Adjustment]
  Select or enter the desired item in the edit dialog box.
  You can enter a name for [Pallet Routine] and [Work Adjustment.] Up to 10 one-byte characters can be used.
- [Execute Condition]
  You can enter or change a command in the same way as you would for point job data. Enter or change a command and click [OK] in the edit dialog box.

■ Copy
Select the desired additional function data number to be copied from the existing data list and click [Copy.]
The selection or entry screen for the copy destination additional function data number will appear. Select or enter the copy destination data number.

■ Delete
Select the desired additional function data number to be deleted from the existing data list and click [Delete.]
TEACHING DATA CHANGE
– SEQUENCER PROGRAM

Sequencer program data is a part of the C&T data. Before creating and editing sequencer program data, you need to open the C&T data.

Click [Sequencer] on the [Data] pull-down menu. The list of sequencer program data will appear.

### New (Add)
Click [Add] in the lower left corner of the box and select a sequencer program data number. The edit dialog box for the selected sequencer program data will appear.

### Edit
To edit existing sequencer program data, select the desired data number to be edited from the list and click [Edit]. The edit dialog box for the selected sequencer program data will appear.

You can enter or change sequencer program data in the same way as you would for point job data. You can enter a name for sequencer program data. Up to 10 one-byte characters can be used.
■ Copy
Select the desired sequencer program data number to be copied from the list and click [Copy.]
The selection or entry screen for the copy destination sequencer program data number will appear.
Select or enter the copy destination data number.

■ Delete
Select the desired sequencer program data number to be deleted from the list and click [Delete.]
TEACHING DATA CHANGE
– RUN MODE PARAMETER

Run mode parameter is a part of the C&T data. Before setting the run mode parameter, you need to open C&T data.
Run mode parameter consists of the following items. Select the desired item to be changed.

- **IO Settings**
  - Program Number Changing Way
  - Program Number Reading Code
  - IO-SYS Function Assignment
  - IO-S Function Setting

- **Job and Sequencer on Run Mode**
  - Job on Power ON
  - Job on Emergency Stop
  - Job on Playback Error
  - Job on System Error
  - Job on Start of Run Mode
  - Job on Start of Cycle
  - Job on End of Cycle
  - Job on Stopping
  - Job on Starting
  - Job while Stopping (Cycle Top)
  - Job while Stopping (In Cycle)
  - Sequencer Program on Run Mode

- **Point Reset Settings**
  - Reset at Power ON
  - Reset at Emergency
  - Reset at Going Home
ROBOT OPERATION VIA PC

To establish communication between the PC and the robot or to operate the robot via the PC, click [Robot] on the menu bar. The following pull-down menu will appear.

- To operate the robot via the PC in the JS series, you need to connect the grip switch to the teaching pendant connector on the control box.
  In the JR2000N series, if a teaching pendant with an emergency stop switch and an enable switch is used, you need to also connect the grip switch to the teaching pendant connector. (See page 3)

- The robot can execute [JOG (JOG Teaching)], [GO Move], and [GO plus Move] operations only in the teaching mode. Enter the teaching mode using the select key switch on the control box.

Be sure to turn off the power to the PC and the robot before inserting or removing the cable.
• If a teaching pendant without an enable switch is used with the JR2000N series, it is not necessary to press the enable switch on the grip switch when instructed to do so in the manual.

■ Mechanical Initialization (for the JR2000N series only)
Execute mechanical initialization of the robot.
Select “Meca Initialize” from “Robot” pull-down menu in the menu bar (while pressing the enable switch.) The robot executes mechanical initialization. The robot will not move unless mechanical initialization is executed after the robot power is turned ON.

■ Motor Power ON (for the JS series only)
Use this function to turn the motor power to the robot ON.
Click [Motor Power ON] on the [Robot] pull-down menu. The motor power to the robot will be turned ON. The robot cannot start unless the motor power is ON.

■ GO Move
Click [GO Move] on the [Robot] pull-down menu while pressing the enable switch.
Each robot Axis will shift to the point coordinates where the cursor blinks.

■ GO plus Move
Click [GO Plus Move] on the [Robot] pull-down menu while pressing the enable switch.
Each robot Axis will shift to the point coordinates where the cursor blinks, and then the cursor will shift to the next point.

■ Point Playback/Test Running
Click [Point Playback] or [Test Running] on the [Robot] pull-down menu while pressing the enable switch.
These two operations will be executed according to the C&T data stored in the robot RAM. For teaching data created using the JR C-Points and stored in the PC, first execute [Send C&T Data] in order to execute [Point Playback] or [Test Running.]
- **JOG (JOG Teaching)**
  Use this function to register point coordinates in JOG mode.
  Place the cursor on the point to be registered and then click [JOG] on the [Robot] pull-down menu. The JOG dialog box will appear. (See next page)
  If you select a point other than normal job points (e.g. work home), click the JOG icon (    ) in the point setting dialog box.

- **Mode, Servo State (for the JS series only)**
  You can select the position entry mode for the robot. If you select [Direct], set [Servo State] to [Free] (Servo OFF.) Any Axis set to [Hold] cannot shift in the Direct mode.
  You can enter the coordinate values in the “Coordinates” (X, Y, Z, R) sections using the numeric keys.
  - If you start the robot in the “Servo Free” (Servo OFF) state, any Axis set to [Free] will not shift. Before starting the robot, set [Servo State] to [Hold] (Servo ON) or change [Mode] to [JOG] When turning to the JOG mode, each Axis automatically will be Servo ON state.

- **Coordinate System (for the JS series only)**
  You can select the coordinate system for the robot. If [J1-J2] is selected, the JOG key function will change from [X, Y, Z, R] to [J1, J2, J3, J4.]

- **Point Number (to be registered)**
  The number of the point where the cursor blinks when opening the dialog box will be displayed here.
  You can change the number. This item will not appear if you do not select a normal job point.

- **Point Job**
  Click the “▼” on the right side of [Point Job] to display the list of the point job data registered in the C&T data. The selected point job data will be executed if you click [Execute] while pressing the enable switch.
  Note that the robot executes the point job data stored in the robot. If the point job data to be executed differs from that stored in the robot, you need to send the data to the robot (execute [Send C&T Data]) first.
• **JOG Key**
Click these buttons while pressing the enable switch on the grip switch. The corresponding robot Axis will shift. Release the button to stop. The Axis display varies according to the selected coordinate system.

• **Speed (for the JS series only)**
You can select the JOG shifting speed between [Low], [Middle], and [High].

• **Coordinates**
The point coordinates where the cursor blinks when opening the dialog box are displayed here.
Click [Robot Pos’n] to display the current robot position coordinates and [Point Pos’n] to display the designated point coordinates.
Click [GO] while pressing the enable switch to shift each robot Axis to the currently displayed position coordinates.

• **Arm Shape**
Select [Righty] or [Lefty] and then click [GO] while pressing the enable switch. The robot will shift to the position coordinates that the selected Arm is pointing to.

• **Register**
Click this button to fix the coordinates and to close the dialog box.
• **GO**
  Click this button while pressing the enable switch. Each robot Axis will shift to the currently displayed position coordinates.

• **Mechanical Initialization (for the JR2000N series only)**
  Execute mechanical initialization of the robot. The robot will not move unless mechanical initialization is executed after the robot power is turned ON.

• **Motor Power ON (for the JS series only)**
  Click this button to turn the motor power to the robot ON. The robot cannot start unless the motor power is ON.

• **Close**
  Click this button to abandon the coordinates and to close the JOG dialog box.

If the JOG dialog box is open, you can shift the robot Axes using the PC keyboard.

<table>
<thead>
<tr>
<th>Axis</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>-X</td>
<td>D</td>
</tr>
<tr>
<td>+X</td>
<td>F</td>
</tr>
<tr>
<td>-Y</td>
<td>E</td>
</tr>
<tr>
<td>+Y</td>
<td>R</td>
</tr>
<tr>
<td>-Z</td>
<td>C</td>
</tr>
<tr>
<td>+Z</td>
<td>V</td>
</tr>
<tr>
<td>-R</td>
<td>T</td>
</tr>
<tr>
<td>+R</td>
<td>Y</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Axis</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>-J1</td>
<td>D</td>
</tr>
<tr>
<td>+J1</td>
<td>F</td>
</tr>
<tr>
<td>-J2</td>
<td>E</td>
</tr>
<tr>
<td>+J2</td>
<td>R</td>
</tr>
<tr>
<td>-J3</td>
<td>C</td>
</tr>
<tr>
<td>+J3</td>
<td>V</td>
</tr>
<tr>
<td>-J4</td>
<td>T</td>
</tr>
<tr>
<td>+J4</td>
<td>Y</td>
</tr>
</tbody>
</table>
If you cannot operate the robot via PC, open “System Information” to confirm the connection between the PC and the robot. If the System Information dialog box opens normally, confirm the following. If you still cannot execute the JOG operation even after having checked all items, try [Diagnosis Mode] (teaching pendant required) or contact your dealer.

**Unable to operate from PC**

- The grip switch is connected.
- The enable switch is pressed.
- Mechanical initialization is executed after the robot power is turned ON.
- The motor power to the robot is ON.
- The robot is in the teaching mode.
- Each robot Axis is in the Servo ON state.

- If a teaching pendant without an enable switch and an emergency stop switch is used with the JR2000N series, a grip switch is not necessary.
- If a teaching pendant without an enable switch is used with the JR2000N series, it is not necessary to press the enable switch.
- For the JR2000N series only
- For the JS series only
- For the JS series only

Set [Mode] to [JOG] in the JOG dialog box. All Axes will automatically be in the Servo ON state.
- **External I/O**

  Click [External I/O] on the [Robot] pull-down menu. The current external I/O status of the robot will be displayed.

  Red lamps indicate the signals currently ON. Click the buttons on the dialog box to toggle the external signals ON or OFF.

- **When Using I/O-U (Optional for the JS series only)**

  I/O-U (optional) is an extension of I/O-H. However, the above I/O-H ON/OFF display is not the I/O-U status because it only displays information on the internal board in the control box.

### With I/O-U

![Diagram of with I/O-U setup]

### Without I/O-U

![Diagram of without I/O-U setup]
EXTERNAL START CHANNEL

External Start
You can select one of the following two channels for the robot to receive the external start signal through. You cannot select both at one time.

- COM1
- I/O-1

Click [External Start] on the [Robot] pull-down menu.
The External Start dialog box will appear.
Select the desired start channel and click [OK.]
Click [System Error Information] or [Run Error Information] on the [Robot] pull-down menu. Any error information regarding the connected robot will be read out and displayed.

If an error occurred while the robot was not connected to the PC, turn off the power to the robot and the PC briefly before connecting the two. Then start up them to read out the error information.
PRINT

You can print out the C&T data.

Click [Print] on the [File] pull-down menu. The Print setting dialog box will appear. Select the desired item to be printed and click [OK]. Set the print range to [All] to select all the C&T data (the unit described on page 10.)

The Print confirmation dialog box will appear. Click [OK] to start printing.

Click [Print Preview] to see the print image. If you want to print out a particular program or point job, locate the page numbers using the Print Preview and then set the page count in the Print dialog box.

Click [Print Setup] to change the print setting.
CUSTOMIZING DATA – TMC SETTING

TMC setting (Teaching Mode Customizing Data) is customizing data which is not restricted by account. Settings can be changed without logging in.

Select the item you want to set from the “Set T.M.C” pull-down menu of in the menu bar. the setting dialog for the selected item will be displayed.

Select the item you want to set from the dialog box and click [OK.]
CUSTOMIZING DATA - ACCOUNT

To define or create customizing data (except for TMC setting), it is necessary to login by setting an account. Up to 50 accounts can be set. Once you login, you remain logged-in under the same account until you logout or terminate JR-CPoints. It is not possible to log in simultaneously using multiple accounts.

Customizing data (except for TMC setting) is protected by account (account restriction.) Access restriction varies depending on the type of “Protect Mode” (See the table below.) Protect Mode can be set for each set of data.

<Access restriction to other accounts>

<table>
<thead>
<tr>
<th>Protect Mode</th>
<th>No Restriction</th>
<th>Public</th>
<th>Protected</th>
<th>Private</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use data</td>
<td>○</td>
<td>○</td>
<td>○</td>
<td>×</td>
</tr>
<tr>
<td>View contents</td>
<td>○</td>
<td>○</td>
<td>×</td>
<td>×</td>
</tr>
<tr>
<td>Change contents</td>
<td>○</td>
<td>×</td>
<td>×</td>
<td>×</td>
</tr>
</tbody>
</table>

■ Login

To login using the existing account, select “Login” from the pull-down menu under “Customize” in the menu bar. The dialogbox shown to the right will be displayed. Enter your Login name and Security Code and click [OK.]
To login using a new account, see “Make Account.”

• This robot has a special account which does not require entry of a Login name (user) and Security Code. This account is useful for creation or setting customizing data which does not require protection by an account.
Logout
To logout, select "Logout" of the pull-down menu from "Account" in the menu bar.

Make Account
To make a new account, select "Make Account" from the pull-down menu under "Customize" in the menu bar. The dialog box shown to the right will be displayed. Enter a Login Name and Security Code twice and click [OK]. You can now login using the new account.

Delete Account
To delete an account, select "Delete Account" from the pull-down menu under "Account" in the menu bar. If an account is deleted, all customizing data included in the account will be deleted too.

Change Security Code
Change the security code used to login.
■ Inhibit Copying
You can choose Valid or Invalid. If "Valid" is set under "inhibit Copying", when C&T data is sent from PC to the robot it will not be sent unless the robot is using the same account.

■ Inhibit Copying to the Other Robot
You can choose Valid or Invalid. If "Inhibit Copying to the Other Robot" is set to "Valid" when C&T data is sent it will not send if the unit identification number is different.

■ Transfer
Transfer all account data being logged in to another account.
Select "Transfer" from the pull-down menu under "Account" in the menu bar and enter an account to transfer to. If data is transferred, all the account data in the original location will disappear.
CUSTOMIZING DATA

- Customizing data is protected by account. It is not possible to edit customizing data through another account. To create or set customizing data, select an account to login under.

Select the customizing data you want to create or set from the pull-down menu under “Customize” in the menu bar. A list of customizing data will be displayed. Click [Add] to create new customizing data. Click [Edit] to modify the existing data. The setting dialog box for the selected item will be displayed.

To copy or delete data, specify the data and select [Copy] or [Delete.]
ROBOT SYSTEM VERSION UPGRADE

Robot system software is built-in system software that controls the robot. Follow the steps below to upgrade the robot system software. “Robot System Software” is the file with the extension “.jsy”, included in Operation Manual CD-ROM.

1. Turn the power to the robot OFF. Remove the switch cover from the front of the control box (for the JS series) or the left side of the robot body (for the JR2000N series) to toggle the special mode switch to ON.
2. Turn the power to the robot ON and insert the Operation Manual CD-ROM into the PC CD drive.


4. Click [Open] and specify the CD drive into which the Operation Manual CD-ROM has been inserted.

5. Select the “Robot System Software” file with the extension “.jsy” and click [Open]. The file name will be displayed in the dialog box title bar.

6. Click [Send] to start sending the robot system software.

7. After the transmission, turn the power to the robot OFF. Toggle the special mode switch to OFF and reattach the switch cover.
CAD DRAWING FILE CONVERSION (Dxf2Robot)

The “Dxf2Robot” software is designed to convert a CAD drawing file (extension “DXF” file) to a file that can be read using JR C-Points.

The converted (extension “JCS”) file can be read using the [Import] function (in the [File] menu) of JR C-Points.

**Preparation**

The “Dxf2Robot” software cannot be installed using the same installation process as for JR C-Points.

Copy the “D2RJ.EXE file from the "JR C-Points" CD-ROM to a local disk.

(Copy Destination Example) C:\Program Files\JANOME\JRPSJ

**Operation**

1. Double-click the D2RJ.EXE icon. The following dialog box will appear.

2. Click [Select (Add)] to select a DXF file to be converted and then click [Open]. The selected file name will be displayed in the “List of source files (DXF Files)” section.

If you want to convert multiple DXF files, repeat this procedure to display the file names in the “List of source files (DXF Files)” section.

To abandon the conversion of a file, select (highlight) the file name to be canceled and click [Cancel.]
3. Click [Browse] to designate a folder to save the converted file(s) into.

4. Click [Convert All.] All the files displayed in the “List of source files (DXF Files)” section will be converted to JCS files and saved in the location selected under “Saving Folder” section. Click [Convert] to convert only the selected (highlighted) file in the “List of source files (DXF Files)” section and save it in the location selected under “Saving Folder” section.

5. After the transmission is complete, click [Exit] to exit “Dxf2Robot.”

Notice
- Up to 500 DXF files can be converted at one time.
- The DXF file to be converted should contain only one layer.
- The DXF file to be converted should not contain either the dimension line, frame, proxy object (zombie), or 3D solid.
- The DXF file to be converted should contain less than 10,000 functions.
  Functions to be converted are as follows:
  ARC (arc), CIRCLE (circle), LINE (line), POINT (point), POLYLINE (continuous line),
  VERTEX (vertex), LWPOLYLINE (continuous line), SEQEND (end of continuous line),
  ENDSEC (end of section)
- An arc will be converted counterclockwise except when an arc and a line are combined.
- A circle will be converted as two arcs. In this case, the start point of the arc is always right side (three o’clock position) of circle.
- The unit of length cannot be converted. Values in the DXF file will be converted directly. You can select either “mm” or “inch” when reading the file with the “JR C-Points.”

PC Operation  54  JS SCARA/JSG GANTRY Robot
JR2000N Desktop Robot
CONVERTING DATA
FROM JR2000 INTO JR2000N

If you are using JR2000 teaching data as JR2000N C&T data, it is necessary to convert the data. To convert data, follow these 3 steps.

1) Using “JR-Points”, load data onto the PC from the JR2000.
2) Using “JR C-Points”, open the data sent in 1).
3) Using “JR C-Points”, send the data from your PC to the JR2000N.

* As well as “JR C-Points”, “JR C-Points Limited Edition (included in Operation Manual CD-ROM)” can also be used to convert data.

● You can connect one PC to both the JR2000 series and the JR2000N series robots together. It is also possible to connect the PC only to the JR2000 series robot to receive teaching data, disconnect the JR2000 robot and then connect the JR2000N series robot to send the teaching data.
(To convert data using one PC, both “JR-Points” and “JR C-Points” have to be installed on the PC.)

Be sure to turn the power to the robot and PC OFF before connecting or disconnecting cables.
Follow the steps below to convert teaching data.
(For a PC with “JR-Points” and “JR C-Points” installed, connected to the JR2000 series and JR2000N series robots.)

1. Turn the power to the robot and PC ON. In Run mode, the robot has to be in stand-by to run. In other modes, it has to be in a base state.

2. Start up “JR-Points” on the PC and set the port status to a COM port connected to the JR2000 series robot.


4. When data transfer is completed, the data is opened in “JR-Points.” Name the received data and save it.

5. Exit “JR-Points” and start up “JR C-Points.”

6. Set the port status to a COM port connected to the JR2000N series robot.

7. Open the data file from the JR2000 series robot.

8. Send the data to the JR2000N series robot. Note that when data is sent from the PC to the robot, any data stored in the robot is deleted.

* For operation environment of “JR-Points”, refer to the operation manual for JR-Points.
COMMUNICATION CABLE (RS-232C) WIRING

Use a 9-pin D-SUB connector for the robot.
The robot is cross-cabled as follows. Use a straight cable when connecting the host (e.g. PC) and the robot.

■ Host Side: 9-Pin D-SUB

COM1 (RS-232C Port)

<table>
<thead>
<tr>
<th>Robot</th>
<th>Host (PC)</th>
</tr>
</thead>
<tbody>
<tr>
<td>PIN No.</td>
<td>Terminal</td>
</tr>
<tr>
<td>3</td>
<td>RXD</td>
</tr>
<tr>
<td>2</td>
<td>TXD</td>
</tr>
<tr>
<td>8</td>
<td>RTS</td>
</tr>
<tr>
<td>7</td>
<td>CTS</td>
</tr>
<tr>
<td>5</td>
<td>GND</td>
</tr>
</tbody>
</table>

Connector: 9-Pin D-SUB

■ Host Side: 25-Pin D-SUB

COM1 (RS-232C Port)

<table>
<thead>
<tr>
<th>Robot</th>
<th>Host (PC)</th>
</tr>
</thead>
<tbody>
<tr>
<td>PIN No.</td>
<td>Terminal</td>
</tr>
<tr>
<td>3</td>
<td>RXD</td>
</tr>
<tr>
<td>2</td>
<td>TXD</td>
</tr>
<tr>
<td>8</td>
<td>RTS</td>
</tr>
<tr>
<td>7</td>
<td>CTS</td>
</tr>
<tr>
<td>5</td>
<td>GND</td>
</tr>
</tbody>
</table>

Connector: 9-Pin D-SUB

For the host (PC) side, use a cable compatible with your PC.
The 9-pin D-SUB is normally connected to the serial port marked with [I O I O] on the rear side of the PC.